How to check UCC is running

As part of normal configuration and troubleshooting procedures, you may need to check whether or not your is up and running. This article describes the ways in which you can do so.

  1. Check if the Service is running in Services.

    Note

    Anywhere365 Service = "Unified Contact Center".

    1. If not, start the service.
    2. If it cannot start, check if there is an error or check the UCC logs.

      C:\ProgramData\Anywhere365\Core\Service\UnifiedContactCenterService\logs

  2. Check if the UCC has a Heartbeat in SCOM or Performance Monitoring

    Tip

    In Performance Monitoring use "Anywhere365 UCC \ Heartbeat" for all instances.

    1. If Heartbeat = 0, then check UCC logs why the UCC didn't start.
    2. If no Heartbeat (No Instance), UCC didn't start after restart. Check UCC logs why the UCC didn't start.
  3. Check if there are Active Presence Subscriptions (Agents).
    • If Active Presence Subscriptions = 0, then check if the Agent are configured correctly and check the UCC logs for errors.
  4. (Only when using Outbound / Direct) Check if the is running in Services.

    Note

    Interceptor Service = "Anywhere365 Sip Interceptor Service"

    1. If not, start the service.
    2. if it cannot start, check if there is an error or check the Interceptor Logs

      Note

      Interceptor logs are located: drive:\Program Files\SipInterceptor\logs

  5. (Only when using Outbound / Direct) Check if the Interceptor has a Heartbeat

    ITip

    n Performance Monitoring use "Anywhere365 Interceptor\ Heartbeat".

    1. If Heartbeat = 0, then check Interceptor logs why the Interceptor didn't start.
    2. If no Heartbeat (No Instance), the Interceptor didn't start after restart. Check the Interceptor logs why the Interceptor didn't start.
  6. Check if the Interceptor is connected to the UCC (Only when using Outbound / Direct).

    Tip

    In Performance Monitoring use "Anywhere365 Interceptor\ Total UCCs".

    • If Total UCC's = 0, then check if the Interceptor config is configured and the correct firewall ports between the Application Server(s) and Front End Server(s) are open.